数据库

Linux 系统 MySQL 完整安装配置教程:从卸载 MariaDB 到优化 my.cnf----《Hello MySQL!》(1)

Linux 系统 MySQL 完整安装配置教程:从卸载 MariaDB 到优化 my.cnf----《Hello MySQL!》(1)

前言 在 Linux 系统中,许多发行版(如 CentOS 7)默认预装 MariaDB(MySQL 的分支项目),但在实际开发、部署场景中,我们常需要安装 MySQL 官方版本以满足特定兼容性或功能需求。然而,新旧数据库环境的冲突、YUM 源配置异常、初始密码登录、中文乱码等问题,往往成为新手入

SE_Meng SE_Meng 2026-04-01
47 0 0
《MySQL 权限与访问进阶:普通用户搭建、跨端登录及 C/C++ 开发对接教程》

《MySQL 权限与访问进阶:普通用户搭建、跨端登录及 C/C++ 开发对接教程》

【一】普通用户的创建 (1)查看user表 user表属于mysql数据库,需先切换 到该库: use mysql; -- 切换到mysql数据库 再在 user 表查看账户: select host,user,authentication_string from user;

SE_Meng SE_Meng 2026-03-18
40 0 0
《MySQL 权限与访问进阶:普通用户搭建、跨端登录及 C/C++ 开发对接教程》

《MySQL 权限与访问进阶:普通用户搭建、跨端登录及 C/C++ 开发对接教程》

【二】使用C语言链接访问库 (1)下载库文件 如果你想要挑战自己,可以去官网下载,再导入: https://dev.mysql.com/downloads/ 如果你是 Ubuntu ,可以终端直接执行下面指令安装库: sudo apt update && sud

SE_Meng SE_Meng 2026-03-17
36 0 0
《MySQL 权限与访问进阶:普通用户搭建、跨端登录及 C/C++ 开发对接教程》

《MySQL 权限与访问进阶:普通用户搭建、跨端登录及 C/C++ 开发对接教程》

【三】语言操作库(接口学习) (1)初始化 mysql_init(null); (2)设置字符集 mysql_options(初始化的mysql指针, MYSQL_SET_CHARSET_NAME, "utf8mb4"); (3)连接MySQL mysql_real_connect(MY

SE_Meng SE_Meng 2026-03-16
34 0 0
MySQL 错误2005解决方案

MySQL 错误2005解决方案

Navicat for MySQL连接出现错误2005! 问题描述 MySQL出现错误2005:2005 -Unknown MySQL server host 'localhost'(0) 解决方案 1、联网!!就这么简单,这是因为在链接属性中“主机名或IP地址”设置为“localh

SE_Meng SE_Meng 2026-03-13
42 0 0
Navicat连接mysql报错2005 -Unknown MySQL server host ‘localhost‘(0)

Navicat连接mysql报错2005 -Unknown MySQL server host ‘localhost‘(0)

Navicat连接mysql报错2005 -Unknown MySQL server host ‘localhost’(0) 在使用Navicat连接MySQL时忽然报错2005, 然后查询连接属性信息,用户名,密码都是正确的 就上网查询了一下、 发现原来是IP地址的问题。 -因为N

SE_Meng SE_Meng 2026-03-12
33 0 0
Navicat连接MySQL出现2059错误解决方法

Navicat连接MySQL出现2059错误解决方法

在Navicat中连接MySQL时遇到错误代码 2059,这表示MySQL服务器不接受Navicat客户端提供的加密插件。MySQL 8.0 及以上版本默认使用 caching_sha2_password 认证插件,可能导致一些客户端。 解决方法: 方法1:将MySQL用户的认证插件改为 mys

SE_Meng SE_Meng 2026-03-11
44 0 0
Navicat连接数据库mysql报错10061

Navicat连接数据库mysql报错10061

在使用nacicat连接docker中的mysql容器时出现了10061的错误 在使用docker安装完mysql8,使用sqlyog或者nacicat连接,需要修改密码加密规则,因为低版本客户端工具不支持mysql8最新的加密规则 docker exec -it mysql bash

SE_Meng SE_Meng 2026-03-10
35 0 0
Docker 安装mysql8.0

Docker 安装mysql8.0

Docker 安装mysql8.0 1.从 Docker Hub 下载 MySQL 8.0 镜像。打开终端并运行以下命令: docker pull mysql:8.0 2. 创建一个 MySQL 容器并运行。在终端中运行以下命令: docker run --name mysql8 -v /m

SE_Meng SE_Meng 2026-03-09
47 0 0
解决 Trae MySQL MCP 连接失败(Fail to start)

解决 Trae MySQL MCP 连接失败(Fail to start)

解决 Trae MySQL MCP 连接失败:从 ENOENT 到认证兼容的全链路实战 在使用 Trae 工具远程访问内网 MySQL 数据库时,我遇到了从本地启动失败到认证兼容报错的一系列问题。经过逐步排查,最终通过本地命令映射+环境变量注入的方式完美解决,现将完整方案分享给大家。 一、问题背

SE_Meng SE_Meng 2026-03-09
127 0 0
1 … 9 10 11 12 13 … 33